32bit automated nightly bundle

From OpenTTD
Jump to: navigation, search


Content.png

Historic content
This page or section contains content that is no longer relevant for the current version of OpenTTD. Please keep it intact because it shows some of the history of this wiki as documentation.
The method of loading 32bpp graphics changed in OpenTTD 1.2.0. The content on this page does not apply to OpenTTD 1.2.0 or newer.

The 32bit automated nightly bundle compiler is a script, run daily, that takes certain kinds of graphics from the 32bit Graphics Development File Repository and bundles them into tars that can be used by players as a graphics set.

The script currently compiles two kinds of packages; a standard version and a dev version.

The nightly bundle does not equal the 32bit base set conversion project, nor is the content necessarily interchangeable. The base set replacement project has its own standards and will feature its own release packages in the future.

Contents

Requirements for inclusion

Specifically, the script takes graphics that meet the following requirements:

  • Type is set to "standard tar".
  • Status is set to "released".

Sprites that would go under "32bpp-extra" are not included, and should be downloaded off the 32bpp-extra project page.

There is a black list in effect - repository entries added on this list are mostly duplicates or the like.

Sprites need to be archived in the tar in the usual way (using one of the game-compatible directory structures). The script will understand the dir tree and organise the sprites accordingly. If you have bundled sources (.blends, textures, photos or whatever) or user information within your tar, don't worry, this script will ignore them and will only organise and bundle png's.

Dev version

The dev version has less strict requirements. In addition to the above, it includes tars that are "visually unfinished", "missing sources" or in "testing".

Functionality

The script will sort the sprites into the 32bit standard tar format. This includes symlinks & all which should make the pack playable on any base set. The pack should also be playable without an -EZ binary but obviously you need -EZ for the closer zoom levels.

See also

External links


Personal tools